tool not identifying data container items when application l

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
hmusku
Posts: 1
Joined: Tue Jun 26, 2018 2:47 pm

tool not identifying data container items when application l

Post by hmusku » Tue Jun 26, 2018 3:04 pm

Hi,
I am using Ranorex 8.0 version and working on desktop application developed with DevExpress controls.

Issue:
when tool launches application and navigates to a window where we have TreeItems/Container(Data), it is not identifying elements under it.If I close that window and open it manually it starts recognizing all the items in Container individually.

please let me know what is the solution for this.

Thanks,
Hari

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3914
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: tool not identifying data container items when application l

Post by odklizec » Thu Jun 28, 2018 9:16 am

Hi,

At first, please update Ranorex with most recent version 8.1.2. Ranorex 8.0 is somewhat old and let's be honest, buggy ;)

If 8.1.2 does not make a difference with your issue, then we may need more information about your app and exact steps you are performing in your test. Also, please if you haven't tried it yet, try to run the Ranorex Studio as administrator and then run your test from it. And finally, post the Ranorex snapshot of problematic container, both if started from the test and started manually. Thanks.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration