TreeItem.Expand does not work correctly

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
besagon
Posts: 8
Joined: Wed Apr 20, 2016 4:12 pm

TreeItem.Expand does not work correctly

Post by besagon » Wed Apr 20, 2016 4:20 pm

Hi

I am automating Eclipse and faced with next problem:
When "Use Java SWT legacy automation mode" is true then everything works fine, but if false then expand method expands tree item but does not show its children. Child elements requested dynamically from server after parent expanded.
Attachments
expand.png
expand.png (11.78 KiB) Viewed 1181 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: TreeItem.Expand does not work correctly

Post by Support Team » Thu Apr 21, 2016 1:15 pm

Hello besagon,

Unfortunately, there is a known issue which could cause such behavior. I would like to double-check if you have the same issue:

1) Please try closing Ranorex Studio and all Ranorex Tools
2) After that, please open Eclipse and navigate to the tree items
3) Open Ranorex Spy and try tracking the elements

Please let me know the result after doing the above-mentioned steps.

Thank you in advance.

Sincerely,
Johannes
.
Image

besagon
Posts: 8
Joined: Wed Apr 20, 2016 4:12 pm

Re: TreeItem.Expand does not work correctly

Post by besagon » Thu Apr 21, 2016 1:38 pm

I repeated your steps and still TreeItem.Expand() method does not expand node correctly (calling Expand() does not start to fetch child elements from the server).
Also I found that TreeItem.Select() works in different way in comparison to "Use Java SWT legacy automaion mode=true" and "Use Java SWT legacy automaion mode=false". In first case it selects some node but other selected nodes are still selected, in second case Select() method firstly unselects all nodes and then selects target node.
Different behavior of methods in different modes cause many problems. F.e. I have large method that does thee navigation and when I switch to "Use Java SWT legacy automaion mode=false" it stops working and I should change my code...

If this is known issues, please tell me when they will be fixed and how I can track this.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: TreeItem.Expand does not work correctly

Post by Support Team » Fri Apr 22, 2016 12:57 pm

Hello besagon,

The above-mentioned bug is slightly different from the issue you are having.

I added the issue concerning the Expand() method to our internal bug-tracking system. Currently, we do not know if and when this bug will be fixed. This depends on various factors. Nevertheless, all reported bugs and feature requests are documented in the release notes, with every new version release of Ranorex.

As a workaround you could try using a DoubleClick action to expand the tree item.

The Select() method in the Java plugin was implemented this way by design. Please note that the Java SWT plugin is basically different from the legacy mode and can't be compared in every aspect.

Thank you for your understanding.

Sincerely,
Johannes
.
Image