Unable to build on VM

Ask general questions here.
rsudhak
Posts: 118
Joined: Fri Jan 04, 2019 1:38 pm

Unable to build on VM

Post by rsudhak » Tue Aug 04, 2020 11:49 pm

HI,

I am getting build errors, I have updated the .net sdk version, but still getting the build errors, works fine on physical machine.
\when build for the first time, ranorex crashes and then only there are build errors which cannot be resolved. This has been reproduced in multiple VM's
Using Ranorex 9.3.1

Attached build errors
Attachments
build error.txt
(63.9 KiB) Downloaded 4 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6180
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Unable to build on VM

Post by odklizec » Wed Aug 05, 2020 8:09 am

Hi,

At first, please install most recent Ranorex 9.3.2 and make sure there are installed all system requirements for this version, as mentioned here:
https://www.ranorex.com/help/latest/ran ... uirements/
At next, the log you posted seems to be incomplete? ideally, please post just the build error (filter-out warnings).
And finally, have you tried to build a small (newly created) sample project?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

User avatar
Stub
Posts: 373
Joined: Fri Jul 15, 2016 1:35 pm

Re: Unable to build on VM

Post by Stub » Wed Aug 05, 2020 8:35 am

We had to install some of the MS Build Tools 2017 to get Ranorex v9.3.2 to build successfully on some of our machines here. I specifically clicked ".NET desktop development" and then selected the ".NET Framework 4.6.2 development tools" but I think maybe it installed something else that was missing as I had the impression that that was already installed following the Ranorex installation. Either way, getting some of the build tools setup resolved the issue for us.
Last edited by Stub on Wed Aug 05, 2020 1:45 pm, edited 1 time in total.

rsudhak
Posts: 118
Joined: Fri Jan 04, 2019 1:38 pm

Re: Unable to build on VM

Post by rsudhak » Wed Aug 05, 2020 1:25 pm

Installing the build tools fixed the issue. Thank you so much

User avatar
Stub
Posts: 373
Joined: Fri Jul 15, 2016 1:35 pm

Re: Unable to build on VM

Post by Stub » Wed Aug 05, 2020 1:47 pm

Oddly enough I hit this exact same issue on another box that I was installing Ranorex onto this very morning. Ranorex v9.3.2 does *NOT* install all the necessary gubbins. So I have updated my answer above to be more precise now that I've had my own refresher!