Unable to detect elements in iOS mobile web.

Mobile Testing, Android App Testing.
Harsh
Posts: 16
Joined: Wed Sep 13, 2017 1:14 am

Unable to detect elements in iOS mobile web.

Post by Harsh » Wed Sep 13, 2017 1:39 am

Hi,
This is my first iOS mobile web test.
I open a url on rx browser. The spy on my PC however only detects the outline of the web page.
It is not able to detect the fields and buttons such as username, password, and Login etc.

Two screenshots are attached.

Can anyone provide feedback, please?

Thank you
Harsh
Attachments
Ipad_Screenshot.jpg
Screenshot from the iPad.
Ipad_Screenshot.jpg (542.33 KiB) Viewed 792 times
2017-09-12_19-21-03.png
Screenshot from the spy on PC.
2017-09-12_19-21-03.png (98.05 KiB) Viewed 792 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3914
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Unable to detect elements in iOS mobile web.

Post by odklizec » Wed Sep 13, 2017 9:18 am

Hi,

Please provide a Ranorex snapshot (not screenshot!) from the app. Screenshot is unfortunately useless. And also please post the xpath in text form. Thanks.

BTW, it would be very useful, if you could post also the HTML page itself (or the HTML code behind it). You see, it would be much easier for support folks to debug the page in rxbrowser and see what's wrong with the page or rxbrowser.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

Harsh
Posts: 16
Joined: Wed Sep 13, 2017 1:14 am

Re: Unable to detect elements in iOS mobile web.

Post by Harsh » Wed Sep 13, 2017 7:40 pm

Thank you for your reply.
I have attached the snapshot and the Html code.
Attachments
Issue_Snapshot.rxsnp
Snapshot is attached.
(84.88 KiB) Downloaded 21 times

Harsh
Posts: 16
Joined: Wed Sep 13, 2017 1:14 am

Re: Unable to detect elements in iOS mobile web.

Post by Harsh » Wed Sep 13, 2017 7:45 pm

The url where I am having issues is 'u2-ts5-qa.egatesoln.com'
I am unable to attach the html code because every time I attempt to attach, I get the message saying 'The upload was rejected because the uploaded file was identified as a possible attack vector.'

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3914
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Unable to detect elements in iOS mobile web.

Post by odklizec » Wed Sep 13, 2017 8:45 pm

Hi, just zip the HTML file and then try to attach it again.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

Harsh
Posts: 16
Joined: Wed Sep 13, 2017 1:14 am

Re: Unable to detect elements in iOS mobile web.

Post by Harsh » Wed Sep 13, 2017 9:09 pm

Web page code attached.
Attachments
WebpageCode.zip
Web page code attached.
(4.25 KiB) Downloaded 24 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3914
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Unable to detect elements in iOS mobile web.

Post by odklizec » Thu Sep 14, 2017 7:35 am

Hi,

I'm currently unable to test the page with iOS, but in snapshot I noticed that you are using an old version of rxbrowser? Please try it with the most recent version 2.3.2.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

Harsh
Posts: 16
Joined: Wed Sep 13, 2017 1:14 am

Re: Unable to detect elements in iOS mobile web.

Post by Harsh » Thu Sep 14, 2017 7:13 pm

Hi,
I updated the rx browser as suggested to 2.3.2.
I also deleted and re installed the service app. In the service app I see the rx browser as one of the instrumented apps.
However, the spy is still not detecting any elements besides the outline of the mobile web page. I tried common websites also like Yahoo.com
Bloomberg.com with no success.

I have attached another snapshot, with rx browser 2.3.2

Thank you for your help.
Harsh
Attachments
Sanpshot2.rxsnp
(592.3 KiB) Downloaded 19 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Unable to detect elements in iOS mobile web.

Post by Support Team » Fri Sep 15, 2017 9:41 am

Hello guys,

Thank you for your posts.

We are currently facing issues with RxBrowser 2.3.2.
Therefore, I would suggest downgrading to 2.3.1 until everything is fixed.

Thank you for understanding.

@Harsh: If the issue still persists with version 2.3.1, please contact us via email ([email protected]) and please attach a Ranorex Snapshot created with this version. Thank you in advance.

regards,

Stephan
.
Image

Harsh
Posts: 16
Joined: Wed Sep 13, 2017 1:14 am

Re: Unable to detect elements in iOS mobile web.

Post by Harsh » Fri Sep 15, 2017 3:28 pm

Hi,
Thank you for your reply. I will roll back the versions and provide feedback.

Harsh

Harsh
Posts: 16
Joined: Wed Sep 13, 2017 1:14 am

Re: Unable to detect elements in iOS mobile web.

Post by Harsh » Sat Sep 16, 2017 11:28 pm

It works fine once I rollback the versions of Ranorex studio, Rxbrowser and RxServiceApp back to 7.1.1.