Unable to find assembly 'log4net, Version=1.2.15.0, Culture=neutral, PublicKeyToken=669e0ddf0bb1aa2a'.

Ranorex Spy, Recorder, and Studio.
Manasarudranna
Posts: 4
Joined: Tue Feb 04, 2020 7:29 am

Unable to find assembly 'log4net, Version=1.2.15.0, Culture=neutral, PublicKeyToken=669e0ddf0bb1aa2a'.

Post by Manasarudranna » Tue Feb 04, 2020 8:43 am

We are using Ranorex 7.1.2 for our endurance testing integrated with our own testing framework and use ranorex only for spying control elements.

Encountering this error since few days, "Unable to find assembly 'log4net, Version=1.2.15.0, Culture=neutral, PublicKeyToken=669e0ddf0bb1aa2a'." while trying to access few elements. I tried copying lognet.dll to Ranorex-> bin but in vain.

Could you kindly help me understand would be deviating and resolve this issue?

Attached Ranorex logs. Let me know if any other info needed.

Regards,
Manasa
Attachments
RanorexLogs.zip
(13.42 KiB) Downloaded 11 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6036
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Unable to find assembly 'log4net, Version=1.2.15.0, Culture=neutral, PublicKeyToken=669e0ddf0bb1aa2a'.

Post by odklizec » Tue Feb 04, 2020 9:54 am

Hi,

At first, you Ranorex version is very...very old and no longer supported. You should definitely consider upgrading it with most recent 9.2.1.

Anyway, your problem sounds like a corrupted .Net or VC runtimes? Please examine the list of system requirements for your version and try to reinstall all requirements:
https://www.ranorex.com/help/latest/ran ... uirements/
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

Manasarudranna
Posts: 4
Joined: Tue Feb 04, 2020 7:29 am

Re: Unable to find assembly 'log4net, Version=1.2.15.0, Culture=neutral, PublicKeyToken=669e0ddf0bb1aa2a'.

Post by Manasarudranna » Mon Feb 10, 2020 4:04 am

Thank you for the reply.
I tried with Ranorex 9.2.1 and encountered 'GUIControlLayerException' at the first control element of the script.
It said 'Genereal error: The type intiliazer error for "Ranorex.core.ElementEngine' threw an exception".

I verified control paths with Ranorex 9.1.2 spy which were identified using Ranorex 7.1.2 and its working fine. No other script change done.
I also checked 'copy runtime to output folder' checkbox under settings and copied 'Ranorex.Core.Resolver.dll' to my output folder but in vain again.

Manasarudranna
Posts: 4
Joined: Tue Feb 04, 2020 7:29 am

Re: Unable to find assembly 'log4net, Version=1.2.15.0, Culture=neutral, PublicKeyToken=669e0ddf0bb1aa2a'.

Post by Manasarudranna » Mon Feb 10, 2020 6:00 am

Attached ranorex trace logs for an above issue:"GUIControlLayerException"
Attachments
ElementEngineError_Logs.zip
(2.58 KiB) Downloaded 9 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6036
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Unable to find assembly 'log4net, Version=1.2.15.0, Culture=neutral, PublicKeyToken=669e0ddf0bb1aa2a'.

Post by odklizec » Mon Feb 10, 2020 9:58 am

Hi,

Could you please post a Ranorex snapshot (NOT screenshot) of the problematic element, eventually, post the snapshot of entire app.

At next, the error you are getting is thrown on the same machine, where you designed your test and also if started from Ranorex Studio?

And finally, have you tried to run Studio/test as administrator?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

Manasarudranna
Posts: 4
Joined: Tue Feb 04, 2020 7:29 am

Re: Unable to find assembly 'log4net, Version=1.2.15.0, Culture=neutral, PublicKeyToken=669e0ddf0bb1aa2a'.

Post by Manasarudranna » Thu Feb 13, 2020 3:39 am

HI,

We have compliant issue in posting snapshot of our app. Can I send it through [email protected]?

User avatar
Support Team
Site Admin
Site Admin
Posts: 12088
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Unable to find assembly 'log4net, Version=1.2.15.0, Culture=neutral, PublicKeyToken=669e0ddf0bb1aa2a'.

Post by Support Team » Thu Feb 13, 2020 2:40 pm

Hi Manasarudranna,

Please create new tickets here: https://www.ranorex.com/support-query/

Looking forward to receiving your request.

Best,
Robert
.
Image