Unable to find items recognized by spy stored in repositor

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
Balam
Posts: 6
Joined: Thu May 14, 2015 11:12 am

Unable to find items recognized by spy stored in repositor

Post by Balam » Fri Jun 05, 2015 8:13 am

Hi,
I'am facing a issue in object identification where i already recognized the element using Ranorex spy and stored in repository,but i can't highlight it when new instance of application is launched i'm sure that it is not a dynamic as i used control name to store it in repository , please help me in solving the issue.
thanks :D
Attachments
ranorexscreen.png
repository repository screen shot
ranorexscreen.png (396.23 KiB) Viewed 913 times
applicationscreenshot.rxsnp
Application ranorex screen shot
(44.41 KiB) Downloaded 63 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3934
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Unable to find items recognized by spy stored in repositor

Post by odklizec » Fri Jun 05, 2015 8:34 am

Hi,

I think you forgot to post the problematic xpath? ;) Anyway, if I understand you right, you have two instances of your app running at the same time? This is the most probable reason of your problem. Please post the problematic xpath.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

Balam
Posts: 6
Joined: Thu May 14, 2015 11:12 am

Re: Unable to find items recognized by spy stored in repositor

Post by Balam » Fri Jun 05, 2015 10:34 am

no i'm not opening the two instance but i'm reopening the application after closing it,
problemetic xpath are as you can see in the screenshot are
1.Globalfrequencyconfigview:?/?/tabpagelist[@name~'^DXTabControlrcWorkSpaceLa']/element[@classname='GlobalFrequencyConfigView']
and the combo boxes an buttons inside it
2.Legal:?/?/tabpagelist[@name~'^DXTabControlrcWorkSpaceLa']/element/combobox[2]/button[@automationid='PART_Item' and @visible='True']
3.Regulator:?/?/tabpagelist[@name~'^DXTabControlrcWorkSpaceLa']/element/combobox[@classname='ComboBoxEdit']/button[@automationid='PART_Item']
4.ButtonCancel:?/?/tabpagelist[@name~'^DXTabControlrcWorkSpaceLa']/?/?/button[@automationid='ButtonCancel']

help is always appreciated :D
Last edited by Balam on Mon Jun 08, 2015 8:12 am, edited 1 time in total.

Fergal
Certified Professional
Certified Professional
Posts: 298
Joined: Tue Feb 18, 2014 2:14 pm
Location: Co Louth, Ireland
Contact:

Re: Unable to find items recognized by spy stored in repositor

Post by Fergal » Fri Jun 05, 2015 11:01 am

Balam wrote:...but i can't highlight it when new instance of application is launched...
Have you tried using Spy, to get the XPath of the element in the new instance and then comparing that with the XPath of the element in your repository?

Balam
Posts: 6
Joined: Thu May 14, 2015 11:12 am

Re: Unable to find items recognized by spy stored in repositor

Post by Balam » Fri Jun 05, 2015 12:42 pm

the whole pane gets easily accesible when i highlight
PortReconSysClientEntitiesRegulator:?/?/list[@automationid='PART_Content']/listitem[1]
which is list item and it is easily recognised also.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3934
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Unable to find items recognized by spy stored in repositor

Post by odklizec » Fri Jun 05, 2015 12:45 pm

I would suggest you to save the Ranorex snapshot both from first and second instance of your app. Then try to check the path in both snapshots. In my opinion, the path in second snapshot will be slightly different? ;)
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

Balam
Posts: 6
Joined: Thu May 14, 2015 11:12 am

Re: Unable to find items recognized by spy stored in repositor

Post by Balam » Mon Jun 08, 2015 5:52 am

when i restart the application i get attached ranorex snapshot! which clearly shows it is not able to recognise elements inside the "Global configuration box" that is "DXTabControlrcWorkSpaceLayout" Please tell me what m i missing :x .
Attachments
newscreenshot.rxsnp
(43.45 KiB) Downloaded 58 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3934
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Unable to find items recognized by spy stored in repositor

Post by odklizec » Mon Jun 08, 2015 7:29 am

Hi,

I'm afraid, I don't have a clue why this happens? Ranorex introduced new WPF plugin in 5.3.0 and there were introduced some WPF changes/improvements in 5.3.1. I see you already using 5.3.2, so you should have all these changes. Let's hope Ranorex folks will have some more ideas what could be a source of your problem. Maybe it's a Ranorex plugin thing, maybe it's something in your app?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Unable to find items recognized by spy stored in repositor

Post by Support Team » Tue Jun 09, 2015 8:00 am

Hello Balam,

I’m afraid that we need further information about your application under test as well as from the test itself. May I ask you to send an email to [email protected]?

Thanks,
Robert
.
Image

Balam
Posts: 6
Joined: Thu May 14, 2015 11:12 am

Re: Unable to find items recognized by spy stored in repositor

Post by Balam » Wed Jun 10, 2015 4:30 am

Already done that!Marcus is helping me out there!