Unable to identify Non GDI element using Ranorex Spy

Ranorex Spy, Recorder, and Studio.
ramanaramidi
Posts: 28
Joined: Wed Feb 26, 2020 6:51 am

Unable to identify Non GDI element using Ranorex Spy

Post by ramanaramidi » Mon Jun 01, 2020 8:29 pm

Hi,

I am unable to identify Non GDI element using ranorex spy using the GDI capture feature. I am able to add the class name to GDI capture list by right clicking on the UI element. But when I track the UI element once again, the element is not captured. Please find the snapshot attached.

Need your support in resolving the issue.


Regards,
Ramana.
Attachments
Non_GDI.rxsnp
(1.33 MiB) Downloaded 5 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6190
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Unable to identify Non GDI element using Ranorex Spy

Post by odklizec » Tue Jun 02, 2020 7:29 am

Hi,

At first, try to reproduce the problem with most recent 9.3.2.

At next, I'm afraid, this kind of issue is hardly solvable via forum and without seeing the problem (and problematic UI) in action. So, I would suggest to create a support ticket and request a remote session with Ranorex folks, so they can analyze the problem directly on your machine. There is really not much anyone here can do or suggest.

BTW, have you tried it on another computer? I remember problems with certain Infragistic controls discussed here at forum. Basically, the problem is in the implementation of accessibility (or lack of thereof) in these controls. And GDI capture is just a workaround, not a perfect solution. GDI capture feature, is usually a last resort how to extract some texts from ancient apps with obsolete UI and is not recommended to be used in wide scale.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

ramanaramidi
Posts: 28
Joined: Wed Feb 26, 2020 6:51 am

Re: Unable to identify Non GDI element using Ranorex Spy

Post by ramanaramidi » Tue Jun 02, 2020 9:12 am

Hi Paval,

Thank s for your reply.

I tried in different machine and observed the same issue. I will get in touch with Ranorex support team.

Thanks,
Ramana.