Unable to identify web element

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
vamsi
Posts: 14
Joined: Thu Dec 11, 2014 12:17 pm

Unable to identify web element

Post by vamsi » Fri Apr 17, 2015 7:12 am

Hi,

While trying to identify a web element i see that in spy it shows as "com.carpathia.atc42s.AnimatedTreeControl" with base type as java.applet.Applet. It is actually a tree item in the web.

regards,
Vami

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3930
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Unable to identify web element

Post by odklizec » Fri Apr 17, 2015 7:19 am

Hi,

Could you please post the Ranorex snapshot (learn here how to create one) of the element in question? Also, what version of Ranorex do you use?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

vamsi
Posts: 14
Joined: Thu Dec 11, 2014 12:17 pm

Re: Unable to identify web element

Post by vamsi » Wed Apr 22, 2015 4:42 am

Hi,

The technology used is version 5.0 of the Animated Tree Control by Carpathia Software.
Information about this control can be found at http://www.carpathia.ro/atc50/ I have attached the ranorex snapshot for your reference.
Attachments
snapshot.rxsnp
snapshot of the control
(96.78 KiB) Downloaded 73 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3930
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Unable to identify web element

Post by odklizec » Wed Apr 22, 2015 8:13 am

Hi,

I'm afraid, Ranorex is not able to identify the elements in this control because it's AWT-based. And as far as I know, AWT accessibility is not yet fully supported by Ranorex. I guess Ranorex folks will feed you with some more details?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Unable to identify web element

Post by Support Team » Thu Apr 23, 2015 3:47 pm

Hi vamsi,

as Pavel wrote, this is unfortunately not supported at the moment. As workaround you could use the image based automation approach.
If you want us to add a feature request please send an email to [email protected].
Thank you.

Regards,
Bernhard
.
Image

vamsi
Posts: 14
Joined: Thu Dec 11, 2014 12:17 pm

Re: Unable to identify web element

Post by vamsi » Thu May 07, 2015 12:24 pm

I tried Image based automation but it is not consistently working. I guess is it is because of the text and the web page gets refreshed a lot while runing the test

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Unable to identify web element

Post by Support Team » Mon May 11, 2015 1:00 pm

Hi vamsi,

It is a little hard to analyze the issue without seeing the behavior of your application.
You could send an email to [email protected] and I or a colleague of mine can schedule a remote session in order to find a workaround.

Regards,
Bernhard
.
Image