Unable to Load Assembly Ranorex.Core.WinApi with WCF Service

Bug reports.
faizmagic
Posts: 2
Joined: Thu Mar 01, 2012 7:43 am

Unable to Load Assembly Ranorex.Core.WinApi with WCF Service

Post by faizmagic » Thu Mar 01, 2012 7:59 am

Hi,

I had been using ranorex for some time now to successfully automate our application, i have downloaded the latest version of ranorex 3.2.2 lib from your web site, after your fix with the memory leak issues.

I have referenced the follwing Ranorex libs Business layers, which invokes a WCF Service, I am getting the following exception when trying to invoke the WCF service, my service has successfully working with the previous version of Ranorex ie 3.2.1, i started getting the issue after upgrading to the new version.

Lib Referred:
1) Ranorex.Controls
2) Ranorex.Core
3) Ranorex.Core.WinApi
4) Ranorex.Libs
5) Ranorex.Libs.IeAddons3
6) Ranorex.Libs.Web
7) Ranorex.Lib.WinForms
8) Ranorex.Plugin.Flex
9) Ranorex.Plugin.Web
10) Ranorex.Plugin.Win32
11) Ranorex.Plugin.WinForms
12) Ranorex.Plugin.Flex

Exception which i Recieved
--------------------------------

The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (application/soap+xml; charset=utf-8). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: '<html>
<head>
<title>Could not load file or assembly 'Ranorex.Core.WinApi' or one of its dependencies. An attempt was made to load a program with an incorrect format.</title>
<style>
body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;}
p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px}
b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px}
H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red }
H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon }
pre {font-family:"Lucida Console";font-size: .9em}
.marker {font-weight: bold; color: black;text-decoration: none;}
.version {color: gray;}
.error {margin-bottom: 10px;}
.expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; }
</style>
</head>

<body bgcolor="white">

<span><H1>Ser'.

Regards
Faiz

faizmagic
Posts: 2
Joined: Thu Mar 01, 2012 7:43 am

Re: Unable to Load Assembly Ranorex.Core.WinApi with WCF Service

Post by faizmagic » Thu Mar 01, 2012 8:31 am

Hi Team,

This issue can be closed. this was mistake from my side, as when i upgraded to 3.2.2, some how my project was still referring to the old version of ranorex libs and hence caused the issues.

Apologies for the same.

Regards
Faiz