Unable to recognize elements in a PDF rendered from Adobe plugin via IE 11

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
lsteinmetzer
Posts: 1
Joined: Fri Oct 16, 2020 5:38 am

Unable to recognize elements in a PDF rendered from Adobe plugin via IE 11

Post by lsteinmetzer » Fri Oct 16, 2020 5:50 am

So, I have a very difficult issue that I am hoping I can find some help on.

Right now we have a test that HAS to find elements in a PDF filed loaded in IE 11 via the Adobe plugin.

This has to be done due to the tool being used to generate this PDF, it only works with IE 11.

Currently I can get SPY to "sometimes" recognize elements within the PDF depending on what machine I am using to run the test. The machines though should all be identical (there mirrored VM's) but for whatever reason it will work on some and not others.

On systems that it does not work on, if I load up the Adobe plugin directly, and attempt to identify elements in a PDF loaded within there, it will not find them either UNLESS I first access preferences. I don't even have to click on anything, just load it up hit save and spy will start finding the elements.

However after doing this, it does NOT carry the setting over to the IE adobe plugin and I still can't identify elements there. On top of that I can't seem to find a specific preferences section just for the IE Adobe plugin.

What very silly thing am I missing here?

I am running Ranorex 9.2.1
Adobe Acrobat Reader DC 2020.006.20042
IE 11.0.210

PDF file doesn't matter I have tried dozens and they all react the same way.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6263
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Unable to recognize elements in a PDF rendered from Adobe plugin via IE 11

Post by odklizec » Mon Oct 19, 2020 7:03 am

Hi,

Could you please upload a sample PDF, so we can examine it with AA and Ranorex spy?

At next, are you able to track the individual PDF elements in Adobe Acrobat viewer (not just AA plugin in IE)? If tracking does not work with standalone AA, it may, of course, don't work with plugin. If tracking works with AA on certain computers, but don;t work on others, then there is most probably something missing on these computers (i.e. correct/the same version of AA, or some of Ranorex pre-requisities, like VC++ runtime libs, .net, etc...). So you must examine these computers side by side and find out the differences.

BTW, you should start with installing most recent Ranorex 9.3.3. Ranorex 9.2.1 is too old, obsolete and no longer supported. It makes no sense to debug such kind of issue with unsupported version.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration