Unable to record or identify Webdocument IE in desktop app

Ask general questions here.
rsudhak
Posts: 118
Joined: Fri Jan 04, 2019 1:38 pm

Unable to record or identify Webdocument IE in desktop app

Post by rsudhak » Wed Dec 18, 2019 3:48 pm

Hi,
I have an AUT, which opens up a dialog which when viewed on spy is of the type Webdocument IE , but when I record, recording fails to do any action on this dialog and is stuck.
On spy too it's not able to identify elements, not only is it slow but also keeps hanging. so I can even create a snapshot.
Any idea how this can be worked on ?
Attached project which I tried to record... and its got elements which could get using CNTL + WIN
Thanks
Attachments
MyTest.7z
(54 KiB) Downloaded 6 times
webdocumentIE.png
webdocumentIE.png (196.67 KiB) Viewed 181 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6168
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Unable to record or identify Webdocument IE in desktop app

Post by odklizec » Thu Dec 19, 2019 8:43 am

Hi,

I'm afraid, that without seeing the app in question and the problematic element, there is not much anyone here can do or suggest.

Apparently, the integrated IE component is a problem? Ranorex does not require Ranorex plugin to be installed in IE (for identification of individual elements). Hovewer, the IE plugin (if installed) dramatically improves the speed of element search and tracking. But I'm afraid, the IE plugin is only available for standalone IE and not the IE-based components. Hence the speed of search in your IE-based dialog can be slower.

The only thing you can probably do, is to add the AUT process name to Ranorex white list, eventually, add also IE process name (iexplore). But I'm not sure if either whitelisted process name with help in case of integrated IE component.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration