Unable to run the tests using Nunit Runner

Ask general questions here.
ramanaramidi
Posts: 28
Joined: Wed Feb 26, 2020 6:51 am

Unable to run the tests using Nunit Runner

Post by ramanaramidi » Sun Mar 01, 2020 9:57 pm

Hi,


My solution uses NUnit as the unit test provider and used NUnit Runner to execute our tests. But I am getting the error "Could not load file or assembly 'Ranorex.Core, Version=9.2.1.0, Culture=neutral, PublicKeyToken=b798506b574ebc9a' or one of its dependencies. The system cannot find the file specified."

Below is the screenshot attached.

Please help.
Attachments
Error.JPG
Error.JPG (47.14 KiB) Viewed 232 times

User avatar
Stub
Posts: 384
Joined: Fri Jul 15, 2016 1:35 pm

Re: Unable to run the tests using Nunit Runner

Post by Stub » Mon Mar 02, 2020 8:42 am

Is that saying .NET v3.5? You need .NET v4.6.2 installed for recent versions of Ranorex.

ramanaramidi
Posts: 28
Joined: Wed Feb 26, 2020 6:51 am

Re: Unable to run the tests using Nunit Runner

Post by ramanaramidi » Mon Mar 02, 2020 8:59 am

I am using .Net v4.6.2 for renorex studio.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6360
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Unable to run the tests using Nunit Runner

Post by odklizec » Mon Mar 02, 2020 9:23 am

Hi,

You must use 4.6.2 (or higher) also everywhere, were you actually RUN the test! So if the test fails to run on target machine (different from where you build it), you must ensure that there are installed all required libs and runtimes as for Ranorex Studio. Ideally, run Ranorex setup on such machine and it will install all missing components. Then you can skip the rest of Ranorex Studio setup ;)
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration