Unable to see elements in STAR McKesson

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
jonny
Posts: 4
Joined: Thu Oct 31, 2019 4:24 pm

Unable to see elements in STAR McKesson

Post by jonny » Thu Oct 31, 2019 6:11 pm

Hi

We're evaluating Ranorex and using STAR to test this. Ranorex is having some trouble identifying things. This also could be my lack of experience too. So wondered if anyone could help me figure this out. I've done a very simple process, I recorded a login. When I re ran it as a test it fails with failed in that it never passed in the credentials to the login box. I saw in the output "Something is limiting object recognition for WinForms. Missing privileges are a common cause of this. Try starting all Ranorex tools and the AUT with the same privileges, preferably as an administrator.
Process: 'NavX' (pid 14444)
https://www.ranorex.com/help/v9.2/inter ... eshooting/
(This message is only shown once per report.) "

I read the help on this and I am an administrator on my system anyway, but ran it as administrator and it the warning still persisted. I have also tried both 32 and 64 bit versions too. I noticed that there wasn't an element associated with the login boxes, even though the cursor has focus there when you access the application. So I tried to spy an object but It couldn't find the element.
ran1.png
ran1.png (114.54 KiB) Viewed 247 times
So I read about the GDI option and tried that, following this link https://www.ranorex.com/help/latest/ran ... e-feature/

But I don't see an option to add a class
ran1.png
ran1.png (114.54 KiB) Viewed 247 times
How could I resolve this?
Attachments
ran2.png
ran2.png (193.79 KiB) Viewed 247 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6168
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Unable to see elements in STAR McKesson

Post by odklizec » Tue Nov 05, 2019 6:02 pm

Hi,

Could you please upload a Ranorex snapshot (NOT screenshot) of the tested app? Without, at very least, snapshot, it’s impossible to suggest something reliable. But I think that on this particular case, it may be required to contact directly Ranorex support and request a remote session with them.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration