Unable to select invisible items from a we dropdown

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
andy.simpson
Posts: 2
Joined: Fri Jun 22, 2018 8:59 am

Unable to select invisible items from a we dropdown

Post by andy.simpson » Fri Jun 22, 2018 9:07 am

Hi,

Just doing a proof of concept but having a few problems selecting an item from a drop down, The elements are shown as being invisible in spy, I have tried disabling the cache in the repository, using delays and invoke ensure visible none of which seem to do the trick. On playback the mose appears to click the top left 0,0 area of the AUT. I have attached a snapshot/screenshot any help would be greatly appreciated

Thanks
Attachments
hidden items in dropdown.rxsnp
(35.41 KiB) Downloaded 6 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3937
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Unable to select invisible items from a we dropdown

Post by odklizec » Mon Jun 25, 2018 12:51 pm

Hi,

How exactly do you select the items? I think you must first click the combo box (to expand it). This should make the invidible items visible, maybe except the items, which are out of the visible screen area? Then the Ensure Visible should work just fine? Another possibility might be to use SetValue action to set select box value. But this may not trigger the onchange event attached to the select box. So I think using Mouse click is the only proper way to select the item in given combo box?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration