unable to work with Outlook email body

Bug reports.
fwason
Posts: 26
Joined: Wed Aug 24, 2011 10:39 pm

unable to work with Outlook email body

Post by fwason » Mon Sep 22, 2014 2:29 pm

I've posted to the forum on Thursday, Sept 18 but have yet to receive a solution, so now I'm takng advantage of our support package. the forum thread is http://www.ranorex.com/forum/wrong-flav ... t6047.html

Essentially, we have a project which tests our add in for MS Outlook. UP to Sept 18, Ranorex was recognizing the email body as a WordDoc, and we were able to enter and read text within that. On Thursday, this changed somehow, and now Ranorex recognizes the object only as an element. We can instrument it as GDI but that doesn't help.... we only get a collection of RawText objects that way.

I have also noticed that one of our 2 development machines is reporting the Caps attribute as uiautomation, and the other as accessible. We are working from the same SVN source, with the same versions of Ranorex, Outlook and Windows.

Other differences also occur besides the WordDoc issue. On the machine that displays "Caps: accessible", all objects are recognized as elements and can't be accessed.

This whole situation is very unfortunate, as we were scheduled to demo our work with the Outlook Addin to the company this past Friday. The demo did not go well.... we had to show past results and state that we're waiting for feedback from the Ranorex support team in order to address an issue which has recently blocked the tests from running....

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: unable to work with Outlook email body

Post by krstcs » Mon Sep 22, 2014 2:52 pm

So, the first question is, what changed on September 18 that made it stop working the way it was?
Was something installed, uninstalled, updated?
Did Windows Update install something?
Check your systems and see if there is anything in the "Installed Updates" for Sept 17 or 18.

This may not be a Ranorex issue. If MS issued an update last week for Office/Outlook, it may have interfered with Ranorex's ability to identify objects. Ranorex will have to have sufficient time to implement and test their solution, if this is the issue.


The next question is, what version of Ranorex are you using?
What version of Windows, Office, etc.?
Shortcuts usually aren't...

fwason
Posts: 26
Joined: Wed Aug 24, 2011 10:39 pm

Re: unable to work with Outlook email body

Post by fwason » Wed Sep 24, 2014 4:26 pm

the information you are requesting exists in the thread I referenced in this post. I had believed that I submitted a support ticket, but interestingly it landed here again, in the FORUM.

in reply to the MS Updates question, no, there are no updates since 9/11. The tests stopped working on 9/18.

as discussed in the other post, nothing changed in the project. The only possible event that might have affected anything was that we made our initial checkin\checkout to the SVN repository on that day. Prior to 9/18, only a single person worked on the project. I had her check it in to SVN so that I could check it out. It just doesn't work on my machine for the apparent reasons stated... unable to make use of Microsoft's UIAutomation\UIAutomationInvoke

**even today, with the original developer's machine, sometimes the WordDoc object is recognized and other times it is recognized as RawText. On dev 2's machine, it is always recognized as RawText
Attachments
FletchForward.rxsnp
snapshot from the machine with FletchReg.txt
(103.49 KiB) Downloaded 80 times
FletchReg.txt
NET registry entries for one machine - no differences in .NET installed (other than dates and sequence)
(45.73 KiB) Downloaded 80 times
NET_REgistry.txt
NET registry entries for the other machine
(45.67 KiB) Downloaded 77 times

fwason
Posts: 26
Joined: Wed Aug 24, 2011 10:39 pm

Re: unable to work with Outlook email body

Post by fwason » Thu Sep 25, 2014 2:41 pm

what is your SLA for defect reports? It is nearly 24 hours since the last update, 4 days since the issue was opened and 1 week since the first request for support

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: unable to work with Outlook email body

Post by krstcs » Thu Sep 25, 2014 2:50 pm

If you need a response from Ranorex Support more quickly, I recommend sending it to [email protected]. If you have a support agreement, include your customer number in the subject. Also, include a link to the forum thread in question.



Also, have you tried a clean re-install on the system that is having the issue?

To perform a clean re-install do the following:

1. Uninstall Ranorex.
2. Reboot the system.
3. Re-install Ranorex using the install executable downloadable at Download Archive

Current version is Ranorex 5.1.3
Shortcuts usually aren't...

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: unable to work with Outlook email body

Post by Support Team » Fri Sep 26, 2014 1:47 pm

Hi fwason,

I think the easiest way is to have a remote session in order to analyze the issue on your machine directly.
Please send an email to [email protected] in order to tell us when a remote session would be possible for you.

Regards,
Bernhard
.
Image