Unerklärliches Verhalten

Ranorex Spy, Recorder, and Studio.
RudolfK
Posts: 9
Joined: Thu Sep 27, 2018 10:26 am

Unerklärliches Verhalten

Post by RudolfK » Mon Mar 09, 2020 3:50 pm

I have a strange behaviour in my soultion with a recording module ( see attachment ). The module is to be retrieved for around 50 times in my solution and sometimes it leads to an error in try 18, 25 or 37 - always unforeseeable

The error message says ""Item ‚ASTI_GesamtRepository.ASTI.MonUsername‘ is no DivTag. The elemet does not support the required Capability „divtag“‘ "

Has anyone an idea why Ranorex behaves like this. I mean 17 ( or 24, 36 ) times it is a DivTag and then suddenly not ???

I also have this phenomenon in another solution with Input fields where Ranorex sometimes says "field is no Input field" although 2 secondes before it was an Input field.

Hope to get some posivite responds here.

Ich habe in meiner Solution ein sehr merkwürdiges Verhalten eines RecordingModule ( siehe Anlage ). Das Module wird an die 50 Mal in der Solution aufgerufen und manchmal bringt es beim 18., 25. oder 37. Versuch ( sehr variabel !! ) die Fehlermeldung "Item ‚ASTI_GesamtRepository.ASTI.MonUsername‘ is no DivTag. The elemet does not support the required Capability „divtag“‘ "

Hat jemand eine Idee was das soll ? Ich meine 17 ( oder 24, 36 ) Mal ist es ein DivTag und dann plötzlich nicht mehr ?

Ich habe dieses Phänomen auch mit InputFelder die bei mehrmaligen Versuchen manchmal die Fehlermeldung "Ist kein Input-Feld" verursachen.

Bin mit meinem Latein ziemlich am Ende und ersuche um Unterstützung.

Liebe Grüße
Rudolf
Attachments
Ranorex_Forum.jpg
Ranorex_Forum.jpg (86.17 KiB) Viewed 264 times
Last edited by RudolfK on Thu Mar 12, 2020 3:51 pm, edited 1 time in total.

User avatar
Support Team
Site Admin
Site Admin
Posts: 12155
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Unerklärliches Verhalten

Post by Support Team » Wed Mar 11, 2020 2:26 pm

Hello Rudolf,

Thank you for your post.
Unfortunately, this is an English forum.
In order to let the community help you, we kindly ask you to post your question in English language.
Therefore, may I ask you to edit your post?

We'd be more than happy to help afterwards.

Kind regards,
Stephan
.
Image

RudolfK
Posts: 9
Joined: Thu Sep 27, 2018 10:26 am

Re: Unerklärliches Verhalten

Post by RudolfK » Thu Mar 12, 2020 3:45 pm

Anstatt mich auf die Sprache hinzuweisen hätten sie auch eine Lösung anbieten können !!

User avatar
RobinHood42
Posts: 324
Joined: Fri Jan 09, 2015 3:24 pm

Re: Unerklärliches Verhalten

Post by RobinHood42 » Fri Mar 13, 2020 2:47 pm

Hey Rudolf,

your last post was in german again. Google translate is saying that you are complaining that they didn't just answer your question. There is a good reason why this forum (like all other technical forums I know) is in english language only. Most users might not speak german and have no idea what you are talking about. They would never know if they have the same issue. Assume someone would reply to your post in russian language. I think you would not be happy.

However, did you try the suggestion in this post:
https://www.ranorex.com/forum/ranorex-9 ... tml#p53074

Cheers,
Robin