"Update" accessibilitylabel value

Mobile Testing, Android App Testing.
SanMan
Posts: 191
Joined: Tue Apr 13, 2010 9:59 am

"Update" accessibilitylabel value

Post by SanMan » Fri Apr 12, 2019 7:16 am

I have this repository element:

/mobileapp[@title='Android OS']//container[@rid='R.id.action_bar_root']/container[@rid='R.id.content']/androidelement/container[@rid='R.id.xwalkWebView']//container[@accessibilitylabel='Name']/form[1]/form[@accessibilitylabel='this_text']

Is there some command (refresh/update/...something) that I could use to update the @accessibilitylabel value?

Now when I run the test and capture screenshot (value is updated there) but this @accessibilitylabel text is not updated.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 4549
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: "Update" accessibilitylabel value

Post by odklizec » Fri Apr 12, 2019 7:25 am

Hi,

Unfortunately, without seeing the app under test or, at very least, Ranorex snapshot, and exact actions leading to incorrect result, there is not much anyone here can do or suggest.

Generally speaking, I would suggest to set “Use cache” for given repo element (and/or its parent folders) to False. This could help with potential content refresh issues?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

SanMan
Posts: 191
Joined: Tue Apr 13, 2010 9:59 am

Re: "Update" accessibilitylabel value

Post by SanMan » Mon Apr 15, 2019 5:55 am

Hi odklizec,

thank you for your answer.

Yes, I have set "Use cache" for this repo without success.

To reproduce this problem, user must login to system to get this status tittle text. I think I need to contact support team and generate access to them to reproduce this problem.