Upgrade to Ranorex ver 7 and the report generated is blank

Ranorex Spy, Recorder, and Studio.
Andrew Simpson
Posts: 22
Joined: Thu Dec 03, 2015 11:58 am

Upgrade to Ranorex ver 7 and the report generated is blank

Post by Andrew Simpson » Thu Apr 06, 2017 12:07 pm

Ranorex version: 7
System: local VM and remote VM running Windows Server 2012r2
Source control and CI: VSO 2013, MTM 2013,


I know there have been several topics on this but think this is slightly different

Upgrading to version 7 the report being generated is blank apart from the template items at the top.

We use a custom report template and this is present in the bin/debug folder and shows on the blank report, you can also access the reports in the bin/debug folder but they also show as blank.
Attachments
Report settings.GIF
Report settings.GIF (64.24 KiB) Viewed 762 times
Blank report.GIF
Blank report.GIF (26.17 KiB) Viewed 762 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3945
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Upgrade to Ranorex ver 7 and the report generated is blank

Post by odklizec » Thu Apr 06, 2017 12:17 pm

Hi,

Ranorex report has been significantly changed in Ranorex 7.0, so I think you will have to update your custom report with Ranorex 7 report format? Please try your test with standard Ranorex report.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Upgrade to Ranorex ver 7 and the report generated is blank

Post by krstcs » Thu Apr 06, 2017 1:54 pm

If you read the release notes, you will see that this was pointed out there. http://www.ranorex.com/release-notes.html

You should ALWAYS read the release notes before upgrading to make sure you understand all of the potential issues involved.
Shortcuts usually aren't...

Andrew Simpson
Posts: 22
Joined: Thu Dec 03, 2015 11:58 am

Re: Upgrade to Ranorex ver 7 and the report generated is blank

Post by Andrew Simpson » Thu Apr 06, 2017 3:39 pm

I have duplicated my project on a separate VM to test ver7 before upgrading fully. I am using tortoisemerge to upgrade the custom report template but where do I get the default transformation files for ver 6 & 7?

Point 2 on link below

http://www.ranorex.com/release-notes/up ... o-7.0.html
Base file: Ranorex default transformation file based on Ranorex 6.x (RanorexReport.xsl)
Their file: Ranorex default transformation file based on Ranorex 7.x (RanorexReport.xsl)
My file: Custom transformation file based on Ranorex 6.x (RanorexReport.xsl)

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Upgrade to Ranorex ver 7 and the report generated is blank

Post by krstcs » Thu Apr 06, 2017 4:36 pm

The easiest way is to find them in the output of projects built with the respective Ranorex versions. You can create fake solutions in each version of Ranorex and run them and they will give you the files in the output folder (<Project Dir>\bin\debug).

Edit to add: Ranorex 6 version of RanorexReport.xsl (zipped)
Attachments
RanorexReport.xsl.zip
(6.09 KiB) Downloaded 38 times
Shortcuts usually aren't...