Urgent: SAP object identification stops working, Randomly

Ranorex Spy, Recorder, and Studio.
skhanpara
Posts: 94
Joined: Wed Apr 23, 2014 3:55 pm

Urgent: SAP object identification stops working, Randomly

Post by skhanpara » Wed Mar 08, 2017 4:27 pm

Hello,

We are facing a issue with SAP webclient and ranorex automation. we're able to identify object sometime while sometimes it does not work.

Report throws following error "http://www.ranorex.com/support/user-gui ... tions.html"

while its already configure accordingly.

Work around:
Close SAP and re-run the script. if this does not work couple of Restart the system.

Ranorex Version: 6.1.0
SAP web client version: 6.0 Final Release PL 8


Thank you
Sunny Khanpara

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3925
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Urgent: SAP object identification stops working, Randomly

Post by odklizec » Thu Mar 09, 2017 9:06 am

Hi,

At first, the Ranorex 6.1.0 is too old and no longer supported. You should update to latest 6.2.1 to be sure your problem is not caused by a bug in 6.1.0.

At next, if the problem is not cleared by the latest Ranorex version, I think it needs to be investigated by Ranorex folks (via remote session). So I would suggest you to contact them at [email protected] and and ask them for a remote session, during which you can show them your problem in "action".
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

skhanpara
Posts: 94
Joined: Wed Apr 23, 2014 3:55 pm

Re: Urgent: SAP object identification stops working, Randomly

Post by skhanpara » Fri Apr 07, 2017 6:19 pm

I tried with Ranorex 7 as well. same issue.

Thank you
Sunny Khanpara

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Urgent: SAP object identification stops working, Randomly

Post by Support Team » Wed Apr 12, 2017 10:07 pm

Hi All,
just to keep you posted.

We are currently in contact with the customer by email and we will update this posting as soon as we have resolved the issue.

Thank you for your patience.

Regards,
Markus (S)
.
Image

skhanpara
Posts: 94
Joined: Wed Apr 23, 2014 3:55 pm

Re: Urgent: SAP object identification stops working, Randomly

Post by skhanpara » Thu Jun 29, 2017 6:55 pm

Hello Markus,

I saw the release note for 7.1 and it says you guys had fix for SAP, but i am facing the same issues.

Let me kno.

Thank you
Sunny Khanpara

skhanpara
Posts: 94
Joined: Wed Apr 23, 2014 3:55 pm

Re: Urgent: SAP object identification stops working, Randomly

Post by skhanpara » Thu Jul 06, 2017 2:55 pm

Thank you Team.

We've able to use it now.

*Note: we need to completely uninstall previous version of Ranorex, before installing Ranorex 7.1.

Thank you
Sunny Khanpara

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Urgent: SAP object identification stops working, Randomly

Post by Support Team » Thu Jul 06, 2017 3:11 pm

Hi Sunny,

Thank you very much for updating this post.
Since the issue has been resolved in Ranorex 7.1, I'll close this thread.
Should you have any additional questions or issues, please feel free to contact us directly at [email protected]

Thank you.

Regards,
Markus (S)
.
Image