Using Deploy Android App action, but cant complete install

Mobile Testing, Android App Testing.
starrdoug99
Posts: 5
Joined: Thu Jul 12, 2012 4:32 pm

Using Deploy Android App action, but cant complete install

Post by starrdoug99 » Mon Oct 20, 2014 9:31 pm

I've created a Ranorex recording that uses the Deploy Android App Action and successfully instruments and deploys my app to my mobile device... sometimes. Most of the time the report says that the Test Suite ran successfully but nothing ever shows up on the mobile device.

The bigger problem is when the app is deployed to the device there is an install verification screen that pops up on the mobile device that must be clicked to allow the app to be installed on the device. I cant figure out a way to automate that step. Any ideas?

Using Ranorex 5.1.3.19973
Ranorex Service 1.6.0
Android 4.0.3

Thank you
Doug

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Using Deploy Android App action, but cant complete install

Post by Support Team » Wed Oct 22, 2014 12:39 pm

Hi Doug,

Regarding the first problem
We are unfortunately not aware of such an issue. May I ask you to send your Ranorex Solution and your Android APK to [email protected]? This will help us to analyze the issue in more detail.
Thank you in advance.

Regarding the second problem
I assume that you are using WiFi as connection type.
Unfortunately an unattended deployment is only possible while using USB connection. Please use USB as connection type in order to instrument and deploy the application without ‘verification screen’.

Regards,
Markus (S)
.
Image