Using V1.5 to test recompiled SUT in .Net 4.0

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
TedB
Posts: 1
Joined: Wed May 23, 2012 1:23 pm

Using V1.5 to test recompiled SUT in .Net 4.0

Post by TedB » Wed May 23, 2012 1:43 pm

Hello,

We programmed/scripted our test automation using Ranorex V1.5.1. and test successfully on our WinForm application.

Now we are migrating (Recompiling) the application from .Net 2.0 to .Net 4.0. But the tests are not working anymore. Huge amount of errors are returned at test run.

How to use the old code to test the recompiled application? is that possible?
Or do we have to scrap many years of tests developement and redo all the tests again?

We planned to migrate to the new version of Ranorex. But before doing so, we want to make sure our first issue is resolved...

Thanks for your help.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Using V1.5 to test recompiled SUT in .Net 4.0

Post by Support Team » Wed May 23, 2012 5:14 pm

TedB wrote:How to use the old code to test the recompiled application? is that possible?
No, sorry. Ranorex 1.X does not (fully) support automating .NET 4.0 WinForms applications. When Ranorex 1.5 was released, the 4.0 .NET Framework version did not even exist, yet.

Unfortunately, there is no easy migration path from Ranorex 1.X to 2.X. That is because Ranorex 2.X (and higher) is rather a new product than just an upgrade of the original 1.X Ranorex. However, you can use all major versions side-by-side. See following forum thread for more details:
http://www.ranorex.com/forum/unhandled- ... tml#p13978

Regards,
Alex
Ranorex Team
.
Image