Versioning Warning Question

Mobile Testing, Android App Testing.
Fergal
Certified Professional
Certified Professional
Posts: 298
Joined: Tue Feb 18, 2014 2:14 pm
Location: Co Louth, Ireland
Contact:

Versioning Warning Question

Post by Fergal » Mon Nov 16, 2015 5:04 pm

Ranorex test reports are showing the error below:
The Android app ‘Ranorex Web Testing’ on device ‘**-*****’ is instrumented with AutomationLib version ‘1.8.3’, which is incompatible with the currently used Ranorex installation. Update your Ranorex installation to fix this issue.
I am using Ranorex 5.4.1.25490 and do not wish to update just yet. Should I change the version of the Ranorex App running on the mobile device (Samsung Galaxy S4)? If so, to which version?

Alternatively, would it be safe to ignore that warning?

Thanks!

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Versioning Warning Question

Post by Support Team » Wed Nov 18, 2015 2:47 pm

Hello Fergal,

The Android service app v1.8.3 is compatible with Ranorex v5.4.0 – v5.4.3. So, you can ignore the warning.
Nevertheless, we highly recommend updating Ranorex to our latest version.

Sincerely,
Robert
.
Image

Fergal
Certified Professional
Certified Professional
Posts: 298
Joined: Tue Feb 18, 2014 2:14 pm
Location: Co Louth, Ireland
Contact:

Re: Versioning Warning Question

Post by Fergal » Thu Nov 19, 2015 10:04 am

Thanks Robert, I have updated to Ranorex 5.4.3 and everything is running as it should now.