Wait For Error

Mobile Testing, Android App Testing.
Seda
Posts: 1
Joined: Fri Apr 19, 2019 12:32 pm

Wait For Error

Post by Seda » Fri Apr 19, 2019 12:54 pm

After clicking on a product i expect to see its image in mobile application.
In order to do this, i use 'Wait for visible'. Wait until the image is shown.
However, when it takes long time, product description to render, "wait for" fails. Even though i give, more than enough time.
If the product page opens right away or fast, "wait for" works just fine.
I want to check whether the product page rendered or not.
Could you please help me?

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 4967
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Wait For Error

Post by odklizec » Tue Apr 23, 2019 8:07 am

Hi,

Unfortunately, It's hard to tell what exactly if wrong, without seeing the app under test and your test suite. I'm not exactly sure what you mean by this:
when it takes long time, product description to render, "wait for" fails. Even though i give, more than enough time.
Do you mean that WaitFor Exists fails, despite element appears within the defined WaitFor timeout? E.g. the timeout is 5m, element appears after 3m, yet WaitFor does not find the element?

In this case, I would guess that the xpath of searched element is different or, that there is required some kind of refresh, which would make the element accessible to Ranorex. Eventually, you simple need to disable Use cache parameter for element's ancestor(s)? But again, it's hard to tell what's wrong, without seeing your app and sample project.

BTW, what Ranorex version do you use? Mot recent is 9.0.1. If you are using something older, please update it. It makes no sense to debug such kind of issue in an obsolete version ;)
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration