We are facing issues to identify the iFrame objects in Googl

Ask general questions here.
md.eshaq
Posts: 4
Joined: Fri Feb 06, 2015 7:25 am

We are facing issues to identify the iFrame objects in Googl

Post by md.eshaq » Tue Apr 07, 2015 6:41 am

Hi,

Do we have good support of Ranorex for iFrame on Chrome.

We are facing issues to identify the iFrame objects in Google Chrome.

NOTE: We are using Ranorex 5.3 and the latest version of Google Chrome.

Regards,
Md.Eshaq

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: We are facing issues to identify the iFrame objects in Googl

Post by krstcs » Tue Apr 07, 2015 3:29 pm

What issue are you facing? I have no problems with iFrames on Chrome or any other supported browser.

Have you tried on Firefox?

Can you identify the element using Ranorex Spy?


Please include more specific information about the issue.

Also, please include a Ranorex Snapshot of the web page and iFrame in Chrome. You can find information on creating a Ranorex Snapshot here.
Shortcuts usually aren't...

md.eshaq
Posts: 4
Joined: Fri Feb 06, 2015 7:25 am

Re: We are facing issues to identify the iFrame objects in Googl

Post by md.eshaq » Wed Apr 08, 2015 5:48 am

Hi

Ranorex is not identifying the iFrame objects in Chrome. The same thing we tried with IE and Firefox and identifies the iFrame objects.

When we try to identify the objects using spy, it recognizes the entire frame but not the individual objects inside the frame.

Please find the attached Ranorex snap shot for your kind reference.

Thanks,
Md.Eshaq
Attachments
Chrome_iFrame_RanorexSnapShot.rxsnp
(53.61 KiB) Downloaded 98 times

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: We are facing issues to identify the iFrame objects in Googl

Post by krstcs » Wed Apr 08, 2015 4:57 pm

Have you installed the Chrome Ranorex addon? You have to download it from the Chrome store, it isn't automatically installed with Ranorex.

Go to the Instrumentation Wizard and select Chrome. It will open the Chrome store to the Ranorex addon's page.
Shortcuts usually aren't...

zero
Posts: 22
Joined: Thu Jan 16, 2014 3:43 pm

Re: We are facing issues to identify the iFrame objects in Googl

Post by zero » Wed Apr 15, 2015 6:45 pm

Same problem here. We can't identify objects in iframes with latest Chrome and Ranorex 5.3.
Our html file is a local one (file:///C:\application.html) and is loading the AUT inside the iframe. I also checked the add-on checkbox "Allow access to file URLs" in the Chrome extension page for the Ranorex plugin, but without effect.

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: We are facing issues to identify the iFrame objects in Googl

Post by krstcs » Wed Apr 15, 2015 7:25 pm

One thing to make sure of is that you specifically include the /iframe element in any path (or ancestor folder) whose element is inside an iframe. My suggestion would be to make the iframe a rooted folder that contains all of the elements inside the iframe.
Shortcuts usually aren't...

zero
Posts: 22
Joined: Thu Jan 16, 2014 3:43 pm

Re: We are facing issues to identify the iFrame objects in Googl

Post by zero » Thu Apr 16, 2015 10:41 am

Thank you krstcs, the //iframe was inside the path. It works in Firefox, but it won't in Chrome. I checked the DOM in Firebug and with the Chrome Debugger.

In Firefox it looks like this:

Code: Select all

<iframe ...>
   <!DOCTYPE html>
In Chrome it looks like this:

Code: Select all

<iframe ...>
    #document
   <!DOCTYPE html>
I don't know if this makes the difference. The iframe can be located in Chrome, but the elements inside not.

zero
Posts: 22
Joined: Thu Jan 16, 2014 3:43 pm

Re: We are facing issues to identify the iFrame objects in Googl

Post by zero » Thu Apr 16, 2015 10:52 am

I think I solved my issue. I stripped everything from the HTML file holding the iframe, since I don't need it anyway. Now it works.

My HTML looks like this:
<!DOCTYPE html>
<html>
<head></head>
<body>
<iframe src="http://SUT.html" style="margin: 0px 0px 0px 10px; width: 750px; height: 600px;"></iframe>
</body></html>
Maybe Chrome had some troubles with the DOM of my document.

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: We are facing issues to identify the iFrame objects in Googl

Post by krstcs » Thu Apr 16, 2015 3:47 pm

You might want to check Chrome's developer tools (hit F12 while on a webpage in Chrome) and see if there are any errors on the page.
Shortcuts usually aren't...

zero
Posts: 22
Joined: Thu Jan 16, 2014 3:43 pm

Re: We are facing issues to identify the iFrame objects in Googl

Post by zero » Thu Apr 16, 2015 5:15 pm

That's what I did and that's why I changed the source html holding the frame. Thanks for your help!

octopus
Posts: 3
Joined: Tue Aug 29, 2017 10:49 am

Re: We are facing issues to identify the iFrame objects in Googl

Post by octopus » Tue Aug 29, 2017 11:08 am

Hi Team,

Same Issue here, Ranorex is not identifying the iFrame objects in Chrome. But it works fine with IE and Firefox

When we try to identify the objects using spy, it recognizes the entire frame but not the objects inside the frame.

Note: Ranorex version(v7.1.0),Chrome version(v60) and Ranorex agent version(v1.0.11) added in Chrome

Kindly help me out on this issue.

asdf
Posts: 174
Joined: Mon Mar 21, 2016 3:16 pm

Re: We are facing issues to identify the iFrame objects in Googl

Post by asdf » Wed Aug 30, 2017 6:39 am

Hi guys,

I think you have to start Chrome with the following flags, in order to identify elements in an iFrame.

Code: Select all

--disable-web-security --user-data-dir="C:\Users\<Username>\AppData\Local\Google\Chrome\User Data"
Hope this helps.

Best regards,
Asdf

octopus
Posts: 3
Joined: Tue Aug 29, 2017 10:49 am

Re: We are facing issues to identify the iFrame objects in Googl

Post by octopus » Thu Aug 31, 2017 1:29 pm

Thanks asdf

I tried by setting the below flag via command prompt

chrome.exe --disable-web-security --user-data-dir="C:\Users\hp\AppData\Local\Google\Chrome\User Data"

and Observed the chrome was getting launched but still iframe objects are not identified by ranorex

Could you please guide us on this

Regards,
Octopus

asdf
Posts: 174
Joined: Mon Mar 21, 2016 3:16 pm

Re: We are facing issues to identify the iFrame objects in Googl

Post by asdf » Thu Aug 31, 2017 1:39 pm

Hi Octopus,

Please try to replace the string from the user data directory with the following one.

Code: Select all

C:\Users\Alice\AppData\Local\Google\Chrome\User Data\Default
You can set the arguments directly in Ranorex Studio over the OpenBrowser-properties pane.
OpenBrowserProps.png
OpenBrowserProps.png (10.83 KiB) Viewed 930 times
Hope this helps.

Sincerely,
asdf

octopus
Posts: 3
Joined: Tue Aug 29, 2017 10:49 am

Re: We are facing issues to identify the iFrame objects in Googl

Post by octopus » Fri Sep 01, 2017 10:29 am

Great asdf, it works fine now :)

Thanks,
Octopus