Web app automation on Firefox 14

Ranorex Spy, Recorder, and Studio.
vnet
Posts: 29
Joined: Tue Jul 24, 2012 8:13 pm

Web app automation on Firefox 14

Post by vnet » Tue Aug 21, 2012 12:36 am

I have automated web app which works fine on IE but when I try to execute same thing on Firefox it doesn't work(except opening the web page). I am using FF 14.0.1 and latest Ranorex . I am making sure that controls have focus before clicking, I checked my RXpath and it's correct and not browser specific and I am giving enough time delay. Am I missing something here? :roll:

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Web app automation on Firefox 14

Post by Support Team » Tue Aug 21, 2012 11:37 am

Hi,

Could you please send us a Ranorex Snapshot file of your web page when it is opened in Firefox and your repository file?
This would help us to analyze the issue.
If you like you can also send it to our support mail address: [email protected]
Following link will show you how to generate a snapshot file:
Creating Ranorex Snapshot Files.

Regards,
Markus
Ranorex Support Team
.
Image

vnet
Posts: 29
Joined: Tue Jul 24, 2012 8:13 pm

Re: Web app automation on Firefox 14

Post by vnet » Tue Aug 21, 2012 5:51 pm

Thanks for the response. I just now sent the snapshot to the support email id from my company email. Look forward to solving this.

vnet
Posts: 29
Joined: Tue Jul 24, 2012 8:13 pm

Re: Web app automation on Firefox 14

Post by vnet » Tue Aug 21, 2012 10:43 pm

so seems like problem was with my code. On opening the web page I get the certification error. I have written a small user code where I check if that particular link is null then check if it's visible, if it is visible then click on it.

This certification error page looks diff on FF, Safari and Chrome. This was the code which was breaking my test(and nothing was happening). I removed the code and things seems to work fine.

My question is, am I doing anything incorrect here? Here is my code-

public void Mouse_Click_Overridelink()
{
if(repo.Overridelink != null)
{
if(repo.Overridelink.Visible == true)
{
Report.Log(ReportLevel.Info, "Mouse", "Mouse Left Click item 'Overridelink' at Center.", repo.OverridelinkInfo);
repo.Overridelink.Click("Center");
}
}
}

User avatar
artur_gadomski
Posts: 207
Joined: Mon Jul 19, 2010 6:55 am
Location: Copenhagen, Denmark
Contact:

Re: Web app automation on Firefox 14

Post by artur_gadomski » Wed Aug 22, 2012 7:23 am

I never tried checking if repository item is null. To check for existance I use Exists method of Info object.
repo.OverridelinkInfo.Exists()

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Web app automation on Firefox 14

Post by Support Team » Wed Aug 22, 2012 9:17 am

Hi,

As Artur said if you want to check if the specific element of your AUT exists you have to use one of the methods of the repository item.
If you check if the repo item is != null, you just check if the repository item object itself exists and not if the element of your web app exists.

Regards,
Markus
Ranorex Support Team
.
Image

vnet
Posts: 29
Joined: Tue Jul 24, 2012 8:13 pm

Re: Web app automation on Firefox 14

Post by vnet » Wed Aug 22, 2012 6:06 pm

Makes sense to me. Thanks for the reply.