WebDoc.EnsureVisible() not working for Edge?

Bug reports.
User avatar
Aracknid
Posts: 342
Joined: Tue Aug 10, 2010 3:23 pm
Location: Toronto, Ontario, Canada

WebDoc.EnsureVisible() not working for Edge?

Post by Aracknid » Mon Oct 15, 2018 7:35 pm

Hi,

Using Ranorex 8.3 and testing against Edge (Windows 10 latest updates to this weekend, Edge version 11.0.17134.345). Using new Edge support added in 8.3, not WebDriver. Coding in VisualStudio using Ranorex API.

In my code, I have a global object for the Web Document of the browser. In my low level framework I always do a call such as MyWebDoc.EnsureVisible() before I try to click on something... In all the other browsers, this brings the window to the front and thus the click actually clicks on the item it is supposed to.

I'm finding in Edge, this never seems to happen. And so I have a lot of issues when I have multiple windows open, or if I'm stepping thru my code while debugging.

Are you able to recreate this?

Aracknid

Edit: Updated first paragraph to include how I'm using Ranorex.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11710
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: WebDoc.EnsureVisible() not working for Edge?

Post by Support Team » Tue Oct 16, 2018 12:14 pm

Hi Aracknid,

Thank you for your post.
We're already aware of this problem and our developers are working on it.
As soon as it is fixed in one of our future releases, you will find the information in our release notes.

regards,
Stephan
.
Image