Webdriver GetChildLineageFrom Uid failed

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
Speedboat
Certified Professional
Certified Professional
Posts: 31
Joined: Wed Mar 25, 2015 4:44 pm
Location: Switzerland

Webdriver GetChildLineageFrom Uid failed

Post by Speedboat » Thu May 11, 2017 10:12 am

Hi

I got the following message displayed in the ranorex progress area:
'GetChildLineageFromUid failed on FlavorElement with flavour 'webdriver'.
Object refrerence not set to an instance of an object.

It occurs frequently with Firefox browser - however the test continues.
Any idea?

Generally:
Firefox is slow through Endpoint WebDriver, while Edge and Chrome are fine.

Ranorex 7.0.1
Selenium Standalone Server 3.4.0
Windows 10 / 64 bit
Firefox 53.0 - 32 bit

Thanks,
Speedboat

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Webdriver GetChildLineageFrom Uid failed

Post by krstcs » Thu May 11, 2017 3:41 pm

Generally these errors are associated with Ranorex attempts to find an item and are harmless. However, there have been times when they are not harmless and can cause issues. If you aren't seeing any issues aside from the text in the progress dialog, then there's really nothing to worry about.

Ranorex throws internal exceptions at different times and catches them (otherwise the test would halt for an uncaught exception). But, they sometimes print these to the debug log, so you may see them on the progress dialog and in the report, if you have the report level set to Debug.

TLDR; unless it's causing failures, you can disregard them.
Shortcuts usually aren't...

Speedboat
Certified Professional
Certified Professional
Posts: 31
Joined: Wed Mar 25, 2015 4:44 pm
Location: Switzerland

Re: Webdriver GetChildLineageFrom Uid failed

Post by Speedboat » Fri May 12, 2017 2:59 pm

Hi krstcs

Good to know!

Thanks,
Speedboat