White or black application window when using Spy

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
Samuel
Posts: 14
Joined: Tue Nov 12, 2013 10:50 am
Location: Germany (BW)

White or black application window when using Spy

Post by Samuel » Tue Nov 19, 2013 3:16 pm

I have the strange problem that all controls inside the application window diappear when I try to locate them using Ranorex Spy (the same happens with Spy++ .. the only difference is that with Spy++ the background seems to always become white while with Ranorex Spy it sometimes becomes black :shock: ).
I attached two images to ilustrate what this looks like.

The problem can be reproduced with different WPF applications (WinForms seems to be working fine).

When the mouse cursor hovers over the controls they become visible again (as shown in picture with black application background).
The preview pictures of the elements inside Ranorex Spy are either completely black or white and clicking "Update Element Data" always causes the controls to disappear.
"Highlight Element" seems to not affect the state of the controls at all (if they were visible before they stay visible and if they were not, the position where they should be is getting highlighted (that´s what I did in the picture with the white application background)).

I should also mention, that I´m currently evaluating Ranorex 4.1.1 and therefore using it inside a VM (with VMwarePlayer, Win7 x32 and verry limited HW ressources).

Thanks and best regards
Samuel
Attachments
whiteScreenCut.jpg
whiteScreenCut.jpg (228.14 KiB) Viewed 792 times
blackScreenCut.jpg
blackScreenCut.jpg (212.17 KiB) Viewed 792 times

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: White or black application window when using Spy

Post by krstcs » Tue Nov 19, 2013 3:29 pm

This is more than likely an issue with the VM not re-drawing correctly due to lack of resources and is not an issue with Ranorex Spy or Spy++.

If you are going to use a VM you must ensure that the VM has enough resources to handle the load. Even when you do that, there may be times when the VM will not re-draw accurately due to load on the host, issues with drivers, etc. You cannot rely on a VM to give accurate renderings.
Shortcuts usually aren't...

Samuel
Posts: 14
Joined: Tue Nov 12, 2013 10:50 am
Location: Germany (BW)

Re: White or black application window when using Spy

Post by Samuel » Thu Nov 21, 2013 8:40 am

I was hoping this particular problem was WPF related and already known, in order to pinpoint what criteria have to be met to avoid it.
In case I want to run tests in parallel on different VMs it would be bad if all screenshots inside the report are like this, or if image based tests fail.

Anyways, I guess I´ll request another trial licence to try it on a different machine..
Thank you for your answer!