Windows application : Cell value is not displayed in the spy tool

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
Noah
Posts: 11
Joined: Tue Aug 21, 2018 1:31 pm

Windows application : Cell value is not displayed in the spy tool

Post by Noah » Mon Jan 28, 2019 11:20 am

Hello all,

I'm working in a windows based application (Java) and there is a table where the row acts as a header section and its cell values contain dates so, when I try to fetch the attribute value of the cell value (i.e date) it does not show in the spy tool instead it recognizes as "cellsection info" .

Could someone please help me with this issue ?
Attachments
Capture Date Field.PNG
Capture Date Field.PNG (837 Bytes) Viewed 225 times
Capture Attribute.PNG
Capture Attribute.PNG (90.5 KiB) Viewed 225 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 5068
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Windows application : Cell value is not displayed in the spy tool

Post by odklizec » Mon Jan 28, 2019 12:08 pm

Hi,

Please upload a Ranorex snapshot (NOT screenshot) of the problematic element. Screenshots are unfortunately useless for UI evaluation and there is not much anyone here can do or suggest from them. All I can suggest right now is to try to "play" with Java-related Ranorex settings. BTW, what Ranorex version do you use? Please make sure you are using the latest one (8.3.2).
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration