Winforms Warnings in Log

Bug reports.
User avatar
Ciege
Ranorex Guru
Posts: 1335
Joined: Thu Oct 16, 2008 6:46 pm
Location: Arizona, USA

Winforms Warnings in Log

Post by Ciege » Wed Apr 13, 2011 4:39 pm

I am receiving a couple of new Winforms warnings in my log with 3.0.1, I did not receive them in 2.x

1) Level - Warn Category - WinForms

Code: Select all

Failed to load the assemblies containing the definition of this control. UI element identification capabilities for this control are limited. Failed assemblies:
The following website provides more information on this technology limitation:
http://www.ranorex.com/support/user-guide-20/technology-instrumentation/general-troubleshooting.html#c3250
(This message is only shown once per report.)
The above warning comes the first time I call this line of code (that particular line of code is called hundreds of times during this particular test):

Code: Select all

Ranorex.Tree HDReportTree = HDReportsForm.FindSingle(".//tree[@accessiblerole='Outline']", 30000);
2) Level - Debug Category - Plugins

Code: Select all

Getting attribute 'title' failed on FlavorElement with flavor 'winforms'. Unable to cast object of type 'Ranorex.Libs.WinForms.ControlProxy' to type 'Ranorex.Libs.WinForms.InvokeResult'.
The above debug message comes when I search for a window using its class. And it does not happen every time I call that code.

Code: Select all

HDReportError = RFW.WaitForWindowWithClass("HD", "#32770", 2);
Which in turn runs this line of code from the WaitForWindowWithClass method in my framework:

Code: Select all

HDForm = Host.Local.FindSingle("/form[@title='" + WindowName + "' or @controlname='" + WindowName + "' and @class='" + strClass + "']", Timeout * 1000);
If this or any response has helped you, please reply to the thread stating that it worked so other people with a similar issue will know how you fixed your issue!

Ciege...

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Winforms Warnings in Log

Post by Support Team » Thu Apr 14, 2011 4:42 pm

Ciege wrote:I am receiving a couple of new Winforms warnings in my log with 3.0.1, I did not receive them in 2.x
Because we did not write any technology limitation as a warning to the report :)
Ciege wrote:1) Level - Warn Category - WinForms
Already explained that warning in the following post:
http://www.ranorex.com/forum/ranorex-te ... t2161.html
Ciege wrote:2) Level - Debug Category - Plugins
You may get this debug message if the communication to a Windows Forms control times out, most probably because the automated application is not responsive. We also noticed that debug message in our own automated tests sometimes and added a few more checks for V3.0.2 that should limit them as good as possible.

Regards,
Alex
Ranorex Team
.
Image

User avatar
Ciege
Ranorex Guru
Posts: 1335
Joined: Thu Oct 16, 2008 6:46 pm
Location: Arizona, USA

Re: Winforms Warnings in Log

Post by Ciege » Thu Apr 14, 2011 5:00 pm

OK, thanks for the information.
If this or any response has helped you, please reply to the thread stating that it worked so other people with a similar issue will know how you fixed your issue!

Ciege...