WinModern 8, Screen Flickers when script is recorded

Ask general questions here.
Brent Arata
Posts: 12
Joined: Mon Jan 27, 2014 10:33 pm

WinModern 8, Screen Flickers when script is recorded

Post by Brent Arata » Mon Jan 27, 2014 11:56 pm

For my problem, whenever I click on a particular button, the screen tends to flicker rapidly. By looking at my view, it seems that the button never reaches to its release state once clicked. In my application, keeping the button in the down state has no effect. Testing on a VM with/or without a remote desktop when the scripts runs on playback show no problems.

The function I use to click on this button is:

Code: Select all

        public static bool Click(Adapter element) {
        	if (element == null) return false;
        	
        	element.EnsureVisible();
        	if(element.Visible)
        	{
        		element.MoveTo();
        		element.Click();
        		return true;
        	}
        	return false;
        }
With the following prerequisites:

Code: Select all

Mouse.DefaultMoveTime = 300;
Keyboard.Enabled = false;
Mouse.Enabled = false;
Keyboard.AbortKey = System.Windows.Forms.Keys.Pause;
Keyboard.DefaultKeyPressTime = 100;
Delay.SpeedFactor = 1.0;
Async dispatching for mouse and touch events is set to false under the advanced settings.

My Ranorex version is 4.1.4

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: WinModern 8, Screen Flickers when script is recorded

Post by Support Team » Thu Jan 30, 2014 4:37 pm

Hello Brent Arata,

Unfortunately I cannot reproduce the issue.
Could you please provide more information about your issue. It would be very helpful if you can provide your application or at least a Ranorex Snapshot file.
Please read the section "Creating Ranorex Snapshot Files" in our user guide in order to get a detailed description how to create a Ranorex Snapshot file.

Regards,
Bernhard
.
Image

Brent Arata
Posts: 12
Joined: Mon Jan 27, 2014 10:33 pm

Re: WinModern 8, Screen Flickers when script is recorded

Post by Brent Arata » Fri Jan 31, 2014 1:55 am

I was able to fix the problem by going to Global Settings -> Plugins, then setting "Force virtual items to be realized" to false under the WPF tab. Not exactly sure why that worked but if someone would like to comment on that, I would appreciate it :D. I tested this on the Surface Pro and the Lenovo Helix.

User avatar
mebner
Posts: 61
Joined: Tue Dec 17, 2013 6:42 pm

Re: WinModern 8, Screen Flickers when script is recorded

Post by mebner » Mon Feb 03, 2014 1:49 pm

Hi Brent,

The setting “Force Virtual Items to be Realized” could influence your tests, since the setting, when it is enabled, forces all items of your e.g. WPF table to get realized (i.e. created) and in some cases to become visible.
This setting allows Ranorex to identify all the items of your e.g tables, even when they are invisible.
If you set it to false, Ranorex is just able to identify the already realized items, which are usually only the visible items.

Do you test a WPF application which includes a table?
Could you see the flickering with other applications too?

Regards,
Markus