WPF Plugin,WpfImprovedOnly: Row,Cell,Text has no values

Bug reports.
aruebesam
Certified Professional
Certified Professional
Posts: 7
Joined: Wed Nov 05, 2014 11:16 am

WPF Plugin,WpfImprovedOnly: Row,Cell,Text has no values

Post by aruebesam » Wed Apr 26, 2017 9:22 am

I'm facing an issue using the following set-up:
- Windows 7
- Ranorex 7.0
- WPF with DevExpress application
- WPF Plugin mode=WpfImprovedOnly, Show All Elements=true

The issue concerns the tracking of cells in a table row. With the above setting the xpath tracked by spy is "row/container/cell/text" but the text element does not contain any attribute values. Expected is that for example text[@text='<displayed value>'], but even so <displayed value> is displayed, none of the text attributes has a value.

When changing the WPF Plugin mode to "UiaOnly", spy tracks the same element with the xpath: "table\container\element\elment[@uiatomationvaluevalue='<displayed value>']

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3922
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: WPF Plugin,WpfImprovedOnly: Row,Cell,Text has no values

Post by odklizec » Wed Apr 26, 2017 9:39 am

Hi,

It would be helpful if you could post a Ranorex snapshot, saved both with WpfImprovedOnly and UiaOnly and if possible, also a small sample app with problematic table. This would be a great help for Ranorex devs ;)
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration